It is currently 14 Nov 2018, 22:29


Compu Chron ?Date? Button Not Working

  • Author
  • Message
Offline

keston

Member

Member

  • Posts: 4
  • Joined: 14 Jan 2017, 20:17
  • Location: Minneapolis, Minnesota, USA

Compu Chron ?Date? Button Not Working

Post23 Jan 2018, 01:01

Hello,

I'm new to the forum, but have been enjoying many of the posts and photos for a while now. I only just starting collecting and repairing digital watches as a hobby. Most of my electronics experience is in electronic music and synthesizer repair, so this is a new challenge for me. I have recently restored a Compu Chron LED watch. When I got it would light up, but it was impossible to set and the buttons were sticky and difficult to press. I have cleaned everything up gotten the buttons working and I'm able to set the watch and use it quite happily.

The only problem it has now is the "date" button at 8 o'clock doesn't do anything (never has since I've owned the watch). I can still see the date by pressing the button at 1 o'clock twice (3 x for seconds). I'm not sure if the 8 o'clock button is even meant to be date, but that's my best guess. The button does nothing no matter if the time is being displayed or not. It also does nothing while setting the watch.

I thought it had to be something to do with connectivity on its way to the IC. However, i did a continuity test between the trace that leads from the button to ground and when I press it it works perfectly. On the module the trace leads to a trimmer pot, or maybe it just runs under it. In any case I'll leave a few photos in case anyone has a similar watch or knows what the problem is, if there even is a problem. For all I know it's operating correctly and I just can't figure out what the button does! ;-)

Image

Image

Image
You do not have the required permissions to view the files attached to this post.
Last edited by keston on 24 Jan 2018, 00:20, edited 2 times in total.
Offline
User avatar

richard_uk

Guru

Guru

  • Posts: 1041
  • Joined: 12 Jul 2004, 16:18

Re: Compu Chron ?Date? Button Not Working

Post23 Jan 2018, 03:04

That module comes with date function at 1, which works how yours does, or with date function at 7 and just time and seconds at 1, so maybe it got fitted with the wrong module, or someone switched it?
Offline

keston

Member

Member

  • Posts: 4
  • Joined: 14 Jan 2017, 20:17
  • Location: Minneapolis, Minnesota, USA

Re: Compu Chron ?Date? Button Not Working

Post23 Jan 2018, 05:53

Ah, that makes sense, but why would the module still have a button contact at 8? Cheaper to keep everything else aside from the functionality the same for mass production?
Offline
User avatar

richard_uk

Guru

Guru

  • Posts: 1041
  • Joined: 12 Jul 2004, 16:18

Re: Compu Chron ?Date? Button Not Working

Post23 Jan 2018, 16:12

There usually isn’t a contact there just the space for one, maybe the wrong chip was put in at the factory?
Offline

keston

Member

Member

  • Posts: 4
  • Joined: 14 Jan 2017, 20:17
  • Location: Minneapolis, Minnesota, USA

Re: Compu Chron ?Date? Button Not Working

Post23 Jan 2018, 18:42

I guess I will just live with it for now. I can obviously access all the functionality, but I will always have a nagging sensation about the useless button at 8 o'clock! ;-)

Return to All other LED watches

Who is online

Users browsing this forum: No registered users and 8 guests